@wordpress/npm-package-json-lint-config Edit

WordPress npm-package-json-lint shareable configuration.

Installation

Install the module

$ npm install @wordpress/npm-package-json-lint-config

Note: This package requires Node.js 12.0.0 or later. It is not compatible with older versions.

Top ↑

Usage

Add this to your package.json file:

"npmpackagejsonlint": {
    "extends": "@wordpress/npm-package-json-lint-config",
},

Or to a .npmpackagejsonlintrc.json file in the root of your repo:

{
    "extends": "@wordpress/npm-package-json-lint-config"
}

To add, modify, or override any npm-package-json-lint rules add this to your package.json file:

"npmpackagejsonlint": {
    "extends": "@wordpress/npm-package-json-lint-config",
    "rules": {
        "valid-values-author": [
            "error",
            [
                "WordPress"
            ]
        ]
    }
},

Or to a .npmpackagejsonlintrc.json file in the root of your repo:

{
    "extends": "@wordpress/npm-package-json-lint-config",
    "rules": {
        "require-publishConfig": "error",
        "valid-values-author": [ "error", [ "WordPress" ] ]
    }
}

Top ↑

Contributing to this package

This is an individual package that’s part of the Gutenberg project. The project is organized as a monorepo. It’s made up of multiple self-contained software packages, each with a specific purpose. The packages in this monorepo are published to npm and used by WordPress as well as other software projects.

To find out more about contributing to this package or Gutenberg as a whole, please read the project’s main contributor guide.